Troubleshooting license related errors in SSIS Powerpack

Home Page Forums Issues – SSIS PowerPack Troubleshooting license related errors in SSIS Powerpack

This topic contains 0 replies, has 1 voice, and was last updated by  ZappySys 3 years, 11 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #1822

    ZappySys
    Keymaster

    Problem:

    When you run SSIS Package inside Visual Studio it works fine but when you run via command line or SQL Agent Job you may get following error. Unfortunately, there is no one reason why such error can happen so please go through possible cause and solution listed in the next section.

    Description: The Execute method on the task returned error code 0x80131500 (License type [SSIS_PP_TRIAL] not found.)

    OR

    System tried to search for the following license types [SSIS_PP_ENT, SSIS_PP_PRO, …….., SSIS_PP_TRIAL] under the following path [C:\ProgramData\ZappySys\SSISPowerPack] but no valid license found. Additional information >>> LoggedInUser=MYDOMAIN\MYSERVICEACCOUNT >> RunAsUser=MYDOMAIN\MYSERVICEACCOUNT >>> Path access=True >> >> TempFolder=C:\Windows\TEMP\ [Read/Write=OK,OK] >> License Files Scanned [2] ==> C:\ProgramData\ZappySys\SSISPowerPack\SSIS_PP_TRIAL.lic.130498499674709531 [Read=OK], . Please read this link for more information => https://zappysys.com/links/?id=10021. Inner error=> License type [SSIS_PP_TRIAL] not found or its expired. You are running TRIAL build, if you have paid license then you must download full version

    Possible Cause(s):

    There could be few possible reasons for license related errors.

    1. If you are running JOB on a cluster environment where Trial License worked fined but Paid License is failing then try these steps
      1. Run your JOB under Proxy account rather than default SQL Agent Account. We found that when JOB runs under SQL Agent Account it reports Cluster Name as MachineName but when License is registered on a Node its tied with Node Machine Name. Running JOB under Proxy account starts reporting Node name as MachineName and license issue goes away.
        More info on this page.
    2. You are running Job using Proxy account and Proxy account is trying to access Temp directory of Sql Agent Service Account (c:\users\MyAgentAccount\AppData\Local\Temp).

      Solution : To fix this issue click here

    3. You have purchased license for Single Task or Bundle but your package is using one or more tasks for which you don’t have license. (e.g. You purchase license for JSON Source and started using REST API Task somewhere in the package)

      Solution : Purchase license for additional tasks/components you are using or Upgrade your version to higher edition (e.g. JSON Source >> JSON Integration Pack >> Standard Edition >> Professional Edition )

    4. One reason for this error could be valid license is not registered (Verify from Start Menu > ZappySys > SSIS PowerPack > LicenseManager). Make sure License is not expired and Status is Valid (Check Status Column in License Manager UI Grid)
      If you don’t see valid License in License Manager UI that means you have to apply valid key.

      Solution :  To apply license check this link

    5. If you have a valid license registered (Based on above check) and you still getting error that means Service Account or User Account used to execute Command line or SQL Agent JOB needs read/write permission for the following path C:\ProgramData\ZappySys

      Solution : Try to register license using Service account ( Check this article for step-by-step instructions ).
      –OR–
      Run JOB Step using Proxy. Here is the tutorial shows how to setup SQL Proxy Account to Run SSIS Job

    6. If you are running JOB using Proxy account (Domain User) and you getting license error in some cases due to missing User Profile and Possible Temp directory.

      Solution : Remote Desktop to Server using Proxy account at least once (This process creates missing User Profile folder including user Temp directory for Proxy user. We have confirmed this helped for many users)

    7. Some Trial user reported that Package is executed successfully under SQL Agent JOB but when you try to execute via SSMS > SSIS Catalog > Execute Package it fails then most likely its possible permission chain issue with the license.

      Solution : Rename C:\ProgramData\ZappySys to something like ZappySys.old and try to execute package again. It will recreate Trial file again with correct Permission chain. ProgramData is hidden folder so if you dont see go to View > Show hidden files and folders.

    8. Some Trial user reported that Package is executed successfully under SSIS Catalog (SSMS > SSIS Catalog > Execute Package) but when try to execute via SQL Agent JOB it fails. This can be most likely permission chain issue with the license. Perform these steps see it helps.

    We find that #3 from above is the most common cause for license failure especially when SQL Agent is running under Custom Service account (Domain service account).

    Many customers reported high success when License registered using Service account or Job step ran under Proxy account rather than default Service account. If you can run any sample package via command line (e.g. dtexec /F "c:\temp\mypackage.dtsx") but cannot execute same package via JOB then its mostly permission issue with Service Account. Check last step (below) how to create Proxy (using different account) to solve this issue.

    Other Information:

    Most common solution

    • Open license manager and make sure you have at least one valid license (e.g. Standard Edition, Trial License)
    • If you already have valid license then make sure task throwing above error is allowed to run under your purchased license type. For example If you purchased JSON Source License but tying to run REST API Task somewhere in that package then system will try to search license types in following order…
      1. Search Standard Edition License … if not found
      2. Search Web API Integration Pack License… if not found
      3. Search for REST API Task License… if not found
      4. Search for TRIAL License… if not found
      5. In none of above found then throw error
    • If you suspect you don’t have correct license then purchase valid license or request Trial extension from us so you can run SSIS packages using SQL Agent or Command line
    • If you have valid license then make sure you assign full permission to SQL Agent Service Account or any other account under which Package is running so it can read/write to C:\ProgramData\ZappySys folder and all sub folders
    • To detect if its permission related issue or not, try to run sample SSIS Package with at least one paid task (e.g. REST API Task). run following command on command line
      dtexec /F "c:\somefolder\yourpackage.dtsx"
    • If above command works fine on command line under your user account but when executed via JOB (under service account) it fails then its most likely permission issue with Service account used by SQL Agent.
    • If you suspect above issue with SQL Agent Job then try to run JOB Step using Proxy account. Here is the tutorial shows how to setup SQL Proxy Account to Run SSIS Job
    • If proxy account also doesn’t help then contact zappysys support
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.