How to fix license error related to SSIS Job Service account

Home Page Forums Issues – SSIS PowerPack How to fix license error related to SSIS Job Service account

This topic contains 0 replies, has 1 voice, and was last updated by  ZappySys 4 years, 8 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #2183

    ZappySys
    Keymaster

    Problem:

    When you run SSIS package using personal account it works fine but when SSIS JOB is executed under service account it fails with the following license error.

    The Execute method on the task returned error code 0x80131500 (System tried to search for following licenses types [SSIS_PP_ENT, SSIS_PP_PRO, SSIS_PP_STD, SSIS_PP_XXXXXXXX,  SSIS_PP_TRIAL] but no valid license found. If you are running Trial version and getting this error then most likely your trial is expired. Please contact support@zappysys.com for trial extension request. If you have applied purchased license key and still getting this error then contact ZappySys. Inner error=> License type [SSIS_PP_TRIAL] not found.).

    Possible Cause:

    Most likely above error is due to permission issue which can be solved using below steps.

    Possible Solution:

    Basically you can register license under Service account using below steps to fix permission related issue.

    1. Press [Windows] + R key and type C:\ProgramData and hot enter (or navigate via windows explorer. Its hidden folder so you may not see by default).
    2. Find ZappySys folder. Rename it to something like ZappySys_old
    3. Now go to where SSIS PowerPack is installed. In most cases it will be C:\Program Files (x86)\ZappySys\SSIS PowerPack (64 bit)
    4. Select LicenseManager.exe from that folder
    5. Hold Shift key and Right click on LicenseManager.exe

      [caption id="attachment_2184" align="alignnone" width="538"]Register License as Service account / Different user Register License as Service account / Different user[/caption]

    6. When prompted enter your Service Account UserName / Password. (e.g. MyDomain\MyServiceAccountName)
    7. Once license Manager is visible make sure no license found in the list. Now click [Add New License] and register your license key.
    8. Try to execute the job again and license error should go away if it was related to permission issue.
    9. If error still persists then it could be other reason listed here.
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.